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FOREWORD

This guide is written for the user of the database application FileMaker Pro 2 on either the
IBM PC compatible using Windows 3.1 and a mouse or a Macintosh computer using System
7. There are some minor differences between using FileMaker Pro on the two computers;
these are explained at appropriate points throughout this guide.

For the IBM PC compatible the guide assumes a basic understanding of how to use the IBM
PC and Windows 3.1. If you are not confident that you have this basic understanding then
read the companion guide: A Student’s Guide to Word for Windows    which contains
the necessary information.

For the Macintosh the guide assumes a basic understanding of how to use the Macintosh and
System 7. If you are not confident that you have this basic understanding then read the
companion guide: A Student’s Guide to Word 5 for Macintosh   which contains the
necessary information.

INTRODUCTION

A database is a store of information, systematically organised, which can be manipulated and
retrieved by issuing instructions to a computer. For example, a database would allow you to
sort a class list into alphabetical order and search for the name of a particular student. The
database can sort or find information much faster than you could by hand so looking through
huge lists of information now becomes a practical proposition. Data can also be manipulated
in a database, eg. you could find out the average age of a student or how many males there
are in a class.

A database is series of records. Each record contains a number of distinct fields which are
defined so as to permit specific types of information to be entered in each field, eg. text,
numbers, dates etc. An example of such a database would be a list of autos that a showroom
has for sale. An example of a record would be information about a particular auto, say a
Vauxhall Nova. Examples of fields are the year of registration, the condition of the auto, and
the date it entered the showroom.

As with databases generally, before you start to use FileMaker Pro you should consider
carefully what information you wish to record, the form in which you wish to record it, and
what data you may want to retrieve from the database.

There are three stages in the creation and use of a database:

• The creation of the database, with the various fields defined so as to reflect the nature
of the information to be recorded (this is done in FileMaker Pro’s Layout mode).

• The entering of data. Information is typed in the fields (this is done in FileMaker Pro’s
Browse mode).

• The sorting, searching and other manipulative operations which can be performed on the
database (this is done in FileMaker Pro’s Browse mode).
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STARTING FILEMAKER PRO

Find the FileMaker Pro 2 icon and double-
click it.

A dialog box is displayed from which you
must create a new database or open an
existing database.

Creating a New Database

Using a Macintosh

Click on the New button in the dialog box presented.

A further dialog box will be displayed from which you can choose where the database is to
be created. Click on the Desktop button to select a different disk drive or folder. Type in a
name for the database and click on the New button to create the database. A dialog box is
displayed, and from this you can define the fields in which data is entered for each record,
see Section 1.3.

Using an IBM PC Compatible

Enter a name for the database into the File Name box, select the disk and directory in which
you wish to save the file and click on the New button. A dialog box is displayed, and from
this you can define the fields in which data is entered for each record, see Section 1.3.

IMPORTANT: Unlike most Macintosh and Windows applications FileMaker Pro requires
that a file is opened before it can be used. As you work, this file is continually updated,
saving your work automatically. There may be times when you wish to experiment with
your database, by changing the layout, for example. As the file is saved automatically,
it would be impossible for you to return to the original layout in the event of your wishing
to abandon the experiment. To prevent this happening use the Save a Copy command
from the File menu. This will save a copy of your database and allow you to return to
it if necessary.

Opening an Existing Database

Using a Macintosh

Click on the Desktop button and select the disk drive where you know the file is saved. Click
on the Open button to reveal the contents of the disk. If the file is stored within a folder click
on the folder to open it, and then select the appropriate file and click on the Open button.

Using an IBM PC Compatible

Select the disk drive where you know the file is saved. If the file is stored within a directory
click on the directory to open it, and then select the appropriate file and click on the OK
button.

Note: Files created by FileMaker Pro for Windows have the extension .fm.

1.2

1.0

1.1
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Defining Fields

A database uses a number of categories or fields in which data is stored. Library catalogs –
cards with author’s name, title of publication, publisher, date of publication – are a case in
point of a physical database now increasingly replaced by an electronic one. Each element
– name, title, publisher etc. – is a field, and these must be defined before data can be entered.

Example Database

Throughout this guide the examples are based on a auto showroom database. The
purpose of the database is to assist the owner of a large auto showroom in keeping track
of the autos that she has for sale along with their particular details. By using a database
she can quickly find out whether a auto in stock meets a purchaser’s requirements.

For each auto the showroom owner wishes the following details to be recorded in the
database.

Manufacturer of auto, eg. Ford, Chrysler, Buick, Renault
Model of auto, eg. Oldsmobile, Mustang, Centura, Skylark
Type of auto, ie. Hatchback, Sedan, Convertible, other
Year of Manufacture, eg. 1986
License Plate Number, eg. DGC912
Date entered showroom, eg. 3/12/93
Condition, ie. A1, Good, Fair, Poor
Faults list, eg. Rust, broken radio
Extended Warranty required, ie. Yes/No
Price paid, eg. $500
Price sold, eg. $1,100
Profit on sale, eg. $600
Profit on sale after commission, eg. $500

When a database is first created the define fields dialog box is displayed. Choose the Define
Fields command from the Select menu. The dialog box below is displayed.

From this dialog box you define fields, and these will be present for each record.

To define a field, type the name you have
chosen for the field into the Name box, click
on the button alongside the type of field
appropriate for the type of data that you
wish the field to display, and click on the
Create button. Repeat the procedure for as
many fields you wish to define. Section 2.1
describes the different field types. Once all
the fields are defined click on the Done
button.

Note: It is not necessary to define all
fields at this stage since they can be
added to a database at any time. Similarly,
the field types and options described
below can be re-defined at any stage.

1.3
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Field Types

To cope with various forms of data, fields are defined with different characteristics. There are
seven types of field – Text, Number, Date, Time, Picture or Sound, Calculation and Summary.

Each field type has particular advantages and disadvantages and special options are
associated with it.

• Text – Used for anything that you can type – letters, numbers or other keyboard symbols.
However, without further definition numbers typed into a text field cannot be used in
calculations.

• Number – Again this field can be used for anything which can be typed. However, only
numbers themselves can be used in calculations. Number fields can be formatted to
include currency symbols (eg. $), a percentage symbol, commas to denote thousands,
a specific number of decimal places etc.

• Date – The format of the date can be specified in the ususal ways.

• Time – The format of the time can be specified in the ususal ways.

• Picture or Sound – Used for ready prepared pictures or sounds. Pictures and sounds can
be pasted or imported in various formats.

• Calculation – Used for calculating with other fields or values and functions you type. See
Section 3.3.

• Summary – A special type of field used to summarise information from a series of records.
See Section 5.18.

Using our example, the Manufacturer of auto would be defined as a text field, the Price
paid would be a number field, and the Date entered showroom would be a date field.

Field options provide increased sophistication
to the field definition. These can be defined
immediately after the field type is defined by
clicking on the Options button. Alternatively,
they can be specified later by choosing the
Define fields command from the Select
menu and, in the dialog box presented,
clicking on the field you wish to change, and
then on the Options button. Either method
will display a dialog box showing options
relating to the field type chosen.

For Text, Number, Time and Date options see
Section 5.15. Calculation options are dealt
with in Section 3.3 and summary options are
covered in Section 5.18.

Once all the fields are defined click on the
Done button.

1.4

14
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ENTERING DATA

Once fields have been defined the database is just an empty shell awaiting the entering of
data.

Before you begin to enter data into your database you should test it out to make sure that
there are no errors and that all the final adjustments have been made. Ask somebody with
experience of designing and using databases to enter some representative test data.

Once the database has been created and tested you can begin to enter your data.

To enter data choose the Browse mode from the Select menu. Browsing is one of the four
modes in FileMaker Pro – the others are Find, Layout and Preview – and it is in this mode which
the data for the database is entered, modified and deleted.

You should now be able to see a list of all the names of the fields which you defined previously.

Note: If no fields are displayed when browsing choose the New Record command from
the Edit menu. If not all fields are displayed use the scroll bars to move around the display
and expose other fields. If the field you wish is still not displayed it may be that you
deleted it from the layout. See Section 5.14.

What is displayed is a single blank record.
Data relating to each field name is entered
into the field itself. This is a transparent box
to the right of the field label. The field
remains transparent until you point and click
on it. Click on one field, and all the fields for
the record become visible. The field is always
to the right of the field label provided no
modification to the layout of the database
has been made.

The field selected ready for data entry is
surrounded by a solid bordered box and has
an insertion point inside. Other fields are
surrounded by dotted bordered boxes.

Data for each record is entered into the fields. To move between fields either click on the field
where you wish to enter data, or press the Tab (     ) key to move to the next field.

Note: Unless you specify otherwise it is not necessary to enter data into every field of a
record. To prevent a particular field from being left blank see Section 5.15.

To move on to a new record once you have completed data entry for a record, choose the
New Record command from the Edit menu.

Tip: If you have a lot of records to enter there is a short cut you can use instead of using
the menu every time you wish to enter a new record. If you are using a Macintosh hold
down the �     key while pressing the N key; if you are using an IBM PC compatible hold
down the Ctrl key while pressing the N key.

2.0
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Entering Data into an Existing Database

Whereas in a new database fields are located to the right of the field labels, this need not be
true of an existing database since fields can be repositioned and the field labels even deleted.

If the layout of the database has been designed well you should not have any difficulty in
locating where to enter data. For more information about Layouts see Section 5.0.

A well designed database will incorporate buttons which remove the necessity to use the
menus for commonly used commands such as New Record. For more information about
Buttons see Section 6.0.

Moving Around a Record

If there are more fields per record than can be displayed on the screen the scroll bars along
the side and/or bottom of the screen become active. To view fields not currently displayed
on the screen use these scroll bars as you would any other Macintosh or Windows application.

Moving Between Records

Displayed on the left of the screen is the
Status Area. The number at the base of the
open book displayed in the upper part of the
Status Area shows you the number of the
record that you are currently browsing.
Underneath the book a count of the total
number of records is displayed.

To move between records click on the lower
page of the book to move to the next record,
and on the upper page to move back a
record. To move more quickly through records
click and drag the book mark up or down.

Note: If you have used the Find command the number of records displayed as counted
will probably be less than the number of records in the database. To ensure that the two
are the same choose the Find All command from the Select menu.

Displaying Several Records Simultaneously

To display records one underneath another choose the View as list command from the
Select menu. Choose the command again to view as normal.

Deleting a Record

Display the record that you wish to delete and choose the Delete Record command from
the Edit menu. See note below.

Editing or Deleting an Entry in a Field

Data entered into a field can be edited in the same way as you would with a word processor.
Use the mouse to move the insertion point within the field, and then type or delete to amend
information entered in the field.

To delete an entry in a field altogether double-click on the field and press the Delete or
Backspace (←) key.

2.2

2.3
Book Book Mark

Current Record 
being browsed

Total Number of 
Records in 
Database file

2.4
2.5
2.6

2.1
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Deleting a Field

Choose the Define Fields command from the Select menu, select the field you wish to
delete, and click on the Delete button. Click on the Done button when finished.

Note: Be careful when deleting records or fields since any data present will also be
deleted Permanently, and there is no way to recover the data.

Changing the Field Name

Choose the Define Fields command from the Select menu, select the field you wish to
rename, type over the field name, and click on the Change button. Click on OK when you
have finished.

Changing the Field Type

Choose the Define Fields command from the Select menu, select the field you wish to
change, and click on the new field type. In certain cases a dialog box will be displayed warning
that the change of type might cause certain characteristics of the data entered into the field
to be lost. Click on the Done button when you have finished.

MANIPULATING THE DATABASE

The intrinsic power of databases is based on the searching, sorting and cross-matching of
records, and on performing calculations based on information stored on a number of
individual records.

Sorting

Each record is stored in the database in the order that it is entered. However, this may not
be the order in which you wish to browse the fields. By sorting the database you can
temporarily rearrange the records according to certain criteria.

To sort the database choose the Sort
command from the Select menu and the
dialog box opposite will be displayed.

From the Field List on the left of the dialog
box select each field on which you wish your
sort to be based and click on the Move
button. This will display the selected fields in
the Sort Order to the right of the dialog box.
Fields will be displayed in the preferred sort
order. Conversely, clicking on the field name
in the sort order and on the Clear button will
remove the field from the sort order. The
Clear All button will remove all fields from
the sort order.

The order of the sort can be changed by clicking and dragging field names up or down the
sort list.

Using the buttons at the bottom of the dialog box you can specify whether the sort for each
field is to be ascending or descending.

2.8

2.9

2.7

3.0

3.1
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Once you are satisfied with the sort order as shown in the right hand side of the dialog box,
click on Sort. The database can be unsorted by again choosing the Sort command from the
Select menu and by clicking on the Unsort button.

Note: Sorting only rearranges the data temporarily. If you add new records, or perform
another search, then the sort you performed previously is lost.

Finding Data

Use the Find mode to search through the database to locate a particular record, or records
conforming to criteria which you wish to specify.

Choose the Find mode from the Select menu. A Find Request Form will be displayed and
all fields will be displayed as blank. Type the search criteria into the relevant field, and click
on the Find button in the Status Area.

The records which conform to the criteria you have specified in the find request form are
termed the Found Set. The Found Set can be browsed using the book in the Status Area,
which will also display the total number of records which conform to the search criteria you
specified.

Notes: Finding is not case sensitive. Use upper or lower case as you prefer.

To return to browsing all records choose the Find All command from the Select menu.

Thus to search for all Ford cars in the autos showroom database, the word Ford would be
entered in the Manufacturer of auto field. Clicking on the Find button would find all Ford
autos for sale in the showroom.

Alternatively, you might wish to base your search on the Year of Manufacture and search for
all autos in the showroom which are manufactured after 1986. To do this, use the Find
symbols from the pop-up menu in the Status Area.

< Less than
≤ Less than or equal to
> Greater than
≥ Greater than or equal to
= Exact match
... Range, eg. 10...12
! Duplicate values
// Today’s date
? Invalid date or time
@ Any one character
* Zero or more characters
“” Literal text, eg. “Yes”

To search for autos manufactured after 1986, enter >1986 into the Year of Manufacture
field.

To find all records with field values which fall within a specific range use the range symbol.
To use our database example to find all autos for sale in the showroom which were
manufactured between 1986 and 1990. You would type 1986...1990 into the Year of
Manufacture field.

To find all values in a field which have duplicates use the ! symbol.

3.2
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Note: If you prefer the Found Set can be copied and Pasted to another application eg.
a wordprocessor. To do this hold down the Option key (Shift (⇑) key with FileMaker Pro
for Windows) while choosing Copy from the Edit menu. Paste as normal in the chosen
application, if pasted to a wordprocessor the Found Set will be pasted delimited by tabs.

See Appendix A for more about exporting to other applications.

Using AND Criteria

All the above examples use only a single
search criteria. However, often it is necessary
to use more than one, eg. if you wish to find
all records of hatchbacks manufactured by
Ford. To do this you need to search the Type
of auto field for hatchback AND the
Manufacturer of auto for Ford. This kind
of search is called an AND search because
the data is found only if it conforms to one
criteria AND another.

Using OR Criteria

OR criteria are useful if you wish to find
records based on one criteria OR another,
eg. if you wish to find records of hatchbacks
OR autos manufactured by Ford.

To find all the records that match one set of
criteria OR another you need to fill out
separate requests. First, enter one set of
search criteria into the appropriate fields,
next choose the New Request command
from the Edit menu. Enter the next set of
criteria into the fields of the new request
form. To search for data which conforms to
both sets of criteria click on the Find button.

To find all autos that are either hatchbacks
OR were manufactured by Ford you would
use the two find request forms opposite.

Note: using OR criteria is not limited only to different fields; you can enter more than one
search criteria into the same field using more than one find request form.

Finding Text

To find records containing a particular word,
phrase, or other text criteria, type the =
symbol, enter the text into the appropriate
field, and then click on the Find button in the
Status Area. This will find all exact incidences
of the text in the field. Thus if the auto

showroom owner wished to search the database for all autos with rust she could enter =rust
in the Faults list field, and click on the Find button.
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Divide (/), Multiply (*), Add (+), 
Subtract (-)

This would find all records with the exact text rust in the faults list field; however slight rust,
rusting gas tank and badly rusted bodywork would not be found.

To find records containing text criteria at the start of a field, enter the text into the field
without the preceding = symbol and click on the Find button in the Status Area. To use our
examples list, entering rust in the Faults list field, and clicking on the Find button would find
all records with the text rust at the start of the field. So rusting gas tank would be found but
slight rust and badly rusted bodywork would not.

To find text with spaces and punctuation, enter text in the field surrounded with double
quotation marks “slight rust”.

Using Wild Cards

To find records containing text criteria no matter where in the field it might be, the Wild Card
characters * and @ are used. The * symbol can be used to represent any number of characters
in the text in a field, whereas the @ symbol is used to represent a single character.

To use our example and search the database
for all autos with rust within any of the text
of the field, the auto showroom owner
could enter *rust* in the faults list field. As
the * symbol represents any number of
characters this would find all records with
the text rust in the faults list field including
slight rust, rusting gas tank and badly rusted
bodywork.

To use @, the single character wildcard, substitute @ instead of any character in the text
search criteria. For example, rust@ would find rusty as well as rust.

Calculating

Calculation fields are used to compute a value from information you have entered into other
fields. This may be combined with constants, and functions. For example, using the auto
showroom database, the owner wishes to calculate and display automatically the profit that
she has made by buying an auto for $500 and selling it for $1,100.

To do this a calculation field must be set-up.
Using the Define Fields command from the
Select menu, enter an appropriate name for
the field in the box provided and click on the
calculation field type button, and then on the
Create button. The following dialog box is
presented into which the formula used to
perform the calculation is entered.

To the left of the dialog box is a scrollable list
of fields already defined which can be used
in the calculation. Just double-click on the
field name to insert it into the calculation.
You are not limited by how many field names
you can use in a calculation, or by how many
times you use a particular field name.

3.3

Divide (/), Multiply (*), Add (+),
Subtract (–)
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The top center of the dialog box displays a selection of buttons showing mathematical
operations that you might wish to use in your formula. Also provided is a key pad which you
can use to enter numbers with the mouse. Click once on any of these buttons to enter your
choice into the formula. Logical operators are available by double-clicking on the operator
list displayed.

Use the mouse to move the insertion point about the formula, editing or deleting as required.
Click on the OK button to return to the define fields dialog box.

Note: If you prefer, field names, mathematical operations, constants, numbers and
functions can be typed directly from the keyboard.

To use our auto showroom example to calculate the profit made on each auto, enter the field
name as Profit on sale and click on Create.

The following formula is used:

Price Sold - Price Paid

By defining the Profit on sale field as a calculation field, the calculation field dialog box is
displayed. To enter the formula double-click on the Price Sold field in the fields list, type a
- (minus) sign or use the dialog keypad, and then double-click on the Price Paid field.

You can also use constants in a formula. For example, a constant is used to calculate the result
of the Profit less commission field. This formula is shown below:

(Price Sold - Price Paid) - 100

Here 100 is the $100 sales staff commission constant.

Functions can be selected from the scrollable functions list in the dialog box and these can
be used in your formula. Parameters of the function are added between the parenthesis after
the function name.

Appendix B contains a summary of the main functions with a short description of each.
Though most functions are self explanatory, the If function requires further explanation,
since it is so useful.

The IF Function

The If function allows the result of a calculation field to be conditional upon certain events.

The function has three parameters: a test; a result if true; a result if false.

If (Test, ResultTrue, ResultFalse)

Using our example auto showroom database, the Profit on sale field could include the If
function. Assuming the Profit on sale depends on whether the extended warranty was
purchased or not. The cost of the extended warranty is $150.

To add this to the existing formula shown above:

If (Extended Warranty required=”Yes”, Price Paid - Price Sold+150, Price Paid - Price
Sold)
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If functions can be nested so that the result of the field can be conditional on more than one
event.

Nested If functions take the form shown below:

If (TestOne, ResultOneTrue, If (TestTwo, ResultTwoTrue, ResultFalse))

Note: The position of the parentheses.

PRINTING

You may have noticed an option under the File Menu called Print. DON’T use this just yet.
First you must decide which printer you are going to use and what you wish to print. This
process is specific to whether you are using FileMaker Pro for Windows or FileMaker Pro for
Macintosh.

Printing From FileMaker Pro for Macintosh

• Choose the Chooser command from the Apple (    ) menu and select from the list of
printers and printer types.

• Choose Page Setup from the File menu. A dialog box similar to the one below will be
presented.

Check that the page orientation is correct. The default page orientation is portrait (upright).
If you wish to print landscape (sideways), click on the appropriate button. Click on OK.

• Choose the Preview mode from the Select menu and you will be shown a ‘bird’s eye
view’ of how the database will appear when printed. This is useful since you can check
that all your layout and print settings are correct. To take a closer look click on the
button and use the scroll bars to move about. If what appears on screen is not exactly
as you wish to print choose the Layout mode from the Select menu to edit the layout.

• Finally, If you are satisfied with the preview choose Print from the File menu. A dialog
box similar to the one below will be displayed.

4.0


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At the bottom of the dialog box you can choose what to print. Click on the Print button to
print your selection.

Note: To print more than one record per page choose the View as list command from
the Select menu.

Printing From FileMaker Pro for Windows

• Choose Print Setup from the File menu and the dialog box will be displayed.

Select the printer you wish to use and check
that the page orientation is correct. The
default page orientation is portrait (upright).
If you wish to print landscape (sideways),
click on the appropriate button. Click on OK.

• Choose the Preview mode from the
Select menu and you will be shown a
‘bird’s eye view’ of how the database will
appear when printed. This is useful since
you can check that all your layout and
print settings are correct. To take a closer
look click on the        button and use the
scroll bars to move about. If what appears
on screen is not exactly as you wish to
print choose the Layout mode from the
Select menu to edit the layout.

• Finally, If you are satisfied with the preview
choose Print from the File menu. The
following dialog box will be displayed.

At the bottom of the dialog box you can
choose what to print. Click on the OK button
to print your selection.

Note: To print more than one record per page choose the View as list command from
the Select menu.

Letter 81/2 x 11 in
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CUSTOMISING THE LAYOUT OF YOUR DATABASE

The layout of the database is important because it makes data entry easier and less prone to
errors. The layout also enables you to focus on those fields of particular interest, since you
do not need to display all fields for which data has been entered.

By default all fields are displayed one underneath each other to the right of their field labels.
This type of layout is called the Standard layout. There are seven pre-defined layouts in all
– see Section 5.1.

Note: The data that you type into the database is independent of the layout that you use,
so choosing not to display a field in a particular layout does not mean that any data typed
into the field is lost, it is merely not displayed.

To examine the current layout choose Layout mode from the Select menu. Each layout is
divided into Parts. There are three parts to the standard layout; the body, the header and the
footer. When in layout mode the parts are displayed on the left of the screen.

Whatever is added to the Header part is
displayed at the top of each record and
whatever is added to the Footer part is
displayed at the bottom of each record. By
default, fields and field labels are displayed in
the Body part.

In the standard layout of the auto showroom
database shown opposite, nothing is
displayed in the header or footer part of the
layout. All defined fields are displayed in the
body part.

Using Pre-Defined Layouts

To use one of the pre-defined layouts choose the Layout mode from the Select menu and
choose New Layout from the Edit menu. The dialog box below is displayed.

Standard: The default Layout. Field labels
with fields alongside. One record per screen
is displayed. A blank header and footer is
included.

Columnar report: Fields in columns from left
to right. Header is included which shows
field names as column headings. A blank
footer is included.

Extended columnar: Fields in columns without
wrapping of fields to the next line. A blank
footer is included.

Single-Page form: One record per screen. No
headers or footers are included.

5.1

5.0
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Label: Fields as printed on standard mailing labels.

Envelope: Fields as printed on a standard envelope.

Blank: Blank layout to which you add fields as required.

Note: You are not restricted to using a single layout for your database; indeed having
more than one layout can be very useful, see Section 5.19.

Altering Layouts

The layout may have been originally defined as one of the pre-defined layouts but there is
nothing to prevent you from customising it in any way you wish. Among the many options
fields can be moved and removed from the layout; field labels can be renamed or removed;
the font, size and style of all entries can be customised; special formats for the field type can
be customised.

Note: Occasionally the horizontal part names and the Status Area get in the way of the
positioning of fields in the layout mode. It can help to position the part names vertically,
to do this click on the            Part label button at the bottom of the window. Click again
to return the part names to their original position. To remove the Status Area click on
the cccccStatus Area display button. To re-instate it, click again.

Items like fields, field labels, graphics etc. are collectively referred to in this guide as objects.

Using Layout Tools

Several tools from the Tools Palette in Status Area are available to assist you in the creation
of layouts.

With the exception of the pointer and text
tools, the other tools available from the tools
palette are geometric objects. To use these,
click on the preferred tool, move the pointer
to the position on the layout where you want
to start drawing, and click and drag until the
shape is the desired size. When you release
the mouse button the shape will be drawn.

Tip: Holding down the Shift ( ⇑) key while drawing an object makes the object
symmetrical eg. using the oval tool while holding down the Shift ( ⇑) key draws a circle.

The Text tool enables you to incorporate text into your layout. Once selected you can click
anywhere in the window and type. See Section 5.4.

The Pointer tool is used to move and resize objects, see Section 5.6.

Font, Size, Style, Alignment and Spacing of Text in Objects

All of these text features can be set before text is entered, or afterwards. In the latter case,
the text to be changed must first be selected.

Use the Font, Size, Style, Spacing and Alignment sub-menus from the Format menu to
amend the text. More than one style can be chosen, and most of the features can be
customised to your own preferences.

5.2

Pointer tool
Text tool

Line tool

Oval tool

Rectangle 
tool

Rounded 
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5.3
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If there are several text attributes that you wish to change at one time it can be easier to use
the Text Format command from the Format menu and use the dialog box presented to
change all the attributes at once.

Note: If you change the text attributes of a field, any entry in the field will change.

Adding Borders Around Fields

Borders can be used to enhance your presentation of fields.

Choose the Layout mode from the Select menu, select the field to which you wish to add
a border, and choose the Field Borders command from the Format menu. The dialog box
below will be displayed.

The left hand section of the dialog box
provides all the border options from which
you can select. The pop-up menu allows you
to specify a format for the border type from
the choice of Borders, Baselines or Fill. Choose
the combination you require and the result is
displayed on the sample to the right of the
dialog box. Click on OK when you have
finished.

The border of more than one field can be added at one time by using the shift-clicking
procedure described in the next section.

Moving and Resizing Objects

To move objects, click and drag them to the required place on the screen. Fields and field
labels are moved independently of one another. However, to move them together, click on
one object and then while holding down the Shift ( ⇑) key click on the other (this is called
Shift-Clicking).

Resizing a field can be useful if the intended data entered is likely to be longer than the current
field will allow, or conversely, if the data entered is much shorter than the space allocated for
it in the standard layout.

Resizing of any object follows the same
procedure. Click on the object once, and
then click and drag one of the handles
displayed at each of the corners.

More than one object can be resized
simultaneously by using the shift-clicking
procedure described earlier in this section,
and this is particularly useful if you wish
several objects to be resized in the same
proportions.

If the exact size of an object is critical select
the object and choose the Size command
from the Layout menu. You can then enter
the required sizes for the object in the dialog
box presented.

handle

Width
Height

5.5

5.6
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Note: the default unit of the size box is the inch. To alter this choose the Ruler Settings
command from the Layout menu and choose the unit from either centimetres or pixels
in the pop-up menu.

Aligning Objects to the Grid

By default an invisible grid is imposed on the layout and objects are aligned to this grid. Using
the grid makes the positioning of objects more precise. However, occasionally you may wish
to turn off the grid. To turn the grid off or on, choose the Align to Grid command from the
Layout menu. With the grid turned on a tick appears alongside the command on the menu.

Positioning Objects Precisely

In addition to the shift-clicking method described in Section 5.6, FileMaker Pro provides
several tools which will assist you to position objects precisely.

Rulers: Using the Rulers command from the Layout menu displays rulers along the top and
left side of the screen.

Ruler lines: Using the Ruler lines command from the Layout menu displays ruler lines on
the screen.

T-square: Using the T-square command from the Layout menu displays T-square lines from
the top to the bottom and across the screen. The position of the T-square can be adjusted
by moving the mouse pointer to the T-square line and clicking and dragging to its new
position. Objects can then be dragged to align with the T-square lines.

Size box: Using the Size command from the Layout menu displays the size box as described
in Section 5.6. The positioning of selected objects can be altered by entering new co-
ordinates into the size box.

All of these options can be used in combination. To remove one of the options choose the
same command again from the Layout menu.

Aligning Objects

There will be occasions when you will wish to align objects with each other.

To do this, select the objects to be aligned,
and use the shift-click method as described
in Section 5.6. Choosing the Alignment
command from the Layout menu displays
the dialog box opposite.

By choosing a combination of top to bottom
and left to right alignment options, the
positioning of the selected objects can be
adjusted. A sample in the dialog box displays
the effect of the chosen alignment. Click on
OK to align the selected objects.

Other objects can be aligned similarly just by
using the Align command from the Layout
menu.

5.9

5.7

5.8
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Deleting Objects

All Objects can be deleted by clicking on the objects and pressing the Delete or Backspace
(←) key.

Deleting a field merely removes the field from the layout it does not delete the field definition.
To delete a field permanently see Section 2.7.

Copying Objects Between Layouts

All objects, including fields, can be cut or copied from one layout to another.

To copy an object leaving the original intact. Choose the Layout mode from the Select menu,
select the object, and choose the Copy command from the Edit menu. Switch to the new
layout and choose the Paste command from the Edit menu. The object will be pasted to the
new layout; its position can be adjusted by clicking and dragging.

To cut the object removing the original, use the same method above but substituting the Cut
command for Copy.

Grouping Objects

Occasionally it can be useful to group objects together so that they can be treated as a single
object. For example, grouping a field and a field label means that they can be moved together
more easily than by using the shift-click method.

To group objects, select all the objects that you wish to group by using the shift-click method
and choose the Group command from the Arrange menu. To ungroup objects, select the
grouped object and choose the Ungroup command from the Arrange menu.

Changing the Stacking Order of Objects

As objects are added to a layout they overlap those already displayed. You can change this
stacking order by selecting the object using the commands in the Arrange menu.

To move an object to the top of the stack choose the Bring to Front command. To move
an object one step towards the top of the stack choose the Bring Forward command. To
move an object one step towards the bottom of the stack choose the Send Backward
command. To move an object to the bottom of the stack choose the Send to Back command.

Adding Pre-defined Fields to a Layout

To add a pre-defined field select the Layout
mode and use the Field tool from the Status
Area.

Click and drag the Field tool to where you
wish the field to appear on the layout. This
displays a dialog box listing all defined fields.
Choose the field you wish to add to the
layout; click in the Create field label box if
you wish to add a field label along with the
field. Click on OK to add the field.

The field is added to the layout and can be re-
positioned in the same way as any other
field.

FieldTool

5.10
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Text, Number, Date and Time Field Options

Text, number, date and time field options are very similar. The same options dialog box is
presented for all four field types. However, not all options are available with each field type
and some options are used more often with particular field types.

The options dialog box shown below is for a text field from the auto showroom example.

Auto-entered Values

Auto-entered values, when checked in the dialog box, allows data to be automatically
entered into a field instead of having to be typed for each record.

The type of auto-entered value can be specified as the creation date, modification date,
modification time, creator name, modifier name.

Using our auto showroom example database,
the Date entered showroom field can be
set up as a date field with an auto-entered
value if it is assumed that the auto details are
entered as soon as the auto enters the
showroom. To do this click on the auto-
entered value type box and use the pop-up
menu to specify creation date as the auto-
entered value. In this way when the record
for the auto is created the date of entry into
the database will be recorded in this field.

To automate the entry of serial numbers click on the a serial number box. You can then enter
the next value of the serial number that you wish to use and the incremental step between
this and the next serial number. For example entering 1000 as the next value and
incrementing by 2 will result in the serial numbers 1000, 1002, 1004, 1006 etc.

Note: If letters are used in the serial number they are ignored for incremental purposes.

If you wish a particular item of data to be auto-entered into the field click on the data box
and enter it in the box provided.

5.15

Auto-entered 
value type box
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Verifying Field Values

Using the options on the right of the dialog box you can verify whether any values entered
in a field conform to certain criteria.

Not empty verifies data is entered in a field.

Tip: it is best to use the not empty option only once you are sure that you have tested
your database sufficiently . This is because every time you create a new record for your
database it will demand that you make an entry in the fields where you have selected
this option. This can become rather tiresome.

Unique verifies entries are different for each record.

An existing value verifies that data entry is of the required type – number, date, time.

From and To verifies that entries fall within a specified range.

Clicking in the Prohibit modification of auto-entered values box will prevent any
alteration of an auto-entered value.

Repeating Fields

Repeating fields allow a field to have more than one value. Using the auto showroom
example, the Faults list field is defined as a repeating field. Thus, notes about each fault
which the auto has can be entered separately into a single field.

To define a repeating field click on the box alongside Repeating field with a maximum of
bbbbvalues. You must also specify the maximum number of values in the box provided.

By default, only the first of the repeating
fields is displayed on the layout. To display all
or some of the repeating fields, choose
Layout mode from the Select menu, select
the field you have defined as repeating and
choose the Field Format command from
the Format menu. The dialog box opposite
will be displayed.

From the lower section of the dialog box you
can enter the number of repetitions you wish
the repeating field to display. In the dialog
box above only 1 of the 8 defined repetitions
will be displayed.

The orientation of the displayed repetitions can be set to either vertical or horizontal.

When using Browse mode pressing the Tab (      ) key will move the insertion point to the
next displayed repetition.

Note: If the field format is changed so that repetitions do not display on the layout, the
data is still stored in the field.

List Display 
Button
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Pre-defined Lists

Using a pre-defined list presents the user of the database with a limited selection of data to
from which to choose to enter for a field. The advantages of this are that it can result in data
entry being faster and more error free.

Click on the Use a pre-defined value list box and a further dialog box will be presented.
Typing a list of all the possible values into this dialog box and pressing the Return or ↵ key
(do not press the Enter key) between each value will provide the user with a limited choice
of entries for the field. Once the value list is entered click on the OK button (do not press the
Return or ↵ key) which will return you to the field options dialog box.

Note: If you wish the user of the database to be able to leave a field with a pre-defined
list blank, when specifying the list make the first entry in the list a blank line by pressing
the Return or ↵ key once before typing in the list.

The value list can be displayed as a menu or as a selection of buttons. To do this, choose
Layout mode from the Select menu, select the field you defined to display the value list,
choose the Field Format command from the Format menu, and the following dialog box
will be displayed.

Click on the list display button and choose the list type required from the pop-up menu.

Types of list display are:

Pop-up List

Clicking on a field formatted as a pop-up list
will display the value list as shown opposite.
The list continues to be displayed until a
choice is made from the menu.

Pop-up Menu

Clicking on a field formatted as a pop-up
menu will display the value list like the example
opposite. Using FileMaker Pro for Macintosh
the list is displayed only while the mouse
button continues to be pressed. Make a
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selection from the list by clicking and dragging to your choice. Using FileMaker Pro for
Windows the list continues to be displayed until a choice is made from the menu.

Check Boxes and Radio Buttons

Using a value list displayed as check boxes or radio buttons a choice can be made by checking
the box or button alongside the value. Unlike radio buttons users are permitted to put a check
in more than one check box.

Check boxes

Radio buttons

Using the auto showroom example, the Type of auto field can be set up as a pre-defined
list. With this field there is a limited number of common choices available – Hatchback, Sedan
or Convertible so a pre-defined list is suitable. However, there are other possible types of auto,
truck or bus for example.

To allow the use of a pre-defined list with this
kind of occasional alternative, from the Field
Format dialog box click on the Include
other item box. This will add an Other...
value to the value list when entering data
into the field. If this value is chosen a dialog
box is presented allowing the user to type in
the alternative data.

Note: Include other item is not available from a pop-up list.

Formatting Values in Defined Fields

Certain values entered into most of the field types can be perfectly valid but not in the format
you require. For example, dates in the 06/03/93 format instead of June 3rd 1993 or 1000
instead of $1,000.

The values entered into these fields can be converted automatically into the required format.

The procedure for formatting values in defined fields is the same for each field type, only the
dialog box which is presented differs.

Text formatting is dealt with in Section 5.4.

To change the value format, choose the Layout mode from the Select menu, select the fields
that you wish to change, and choose the appropriate format command from the Format
menu. A dialog box will be presented from which you can format the values click on OK when
you have completed changing the format.

Note: If the title of the dialog box reads Default Field Type Format, where Field Type
is the type of format chosen from the Format menu it means that you do not have a field
selected. Altering the options of the Default Format will set the format for any fields of
this type that you add later.

Formatting Fields Containing Numerical Values

Number fields, most calculation fields and summary fields contain numbers which can be
displayed and printed in a variety ways. Numbers can be formatted with a specific number
of decimal places, preceded with a $ sign, followed by a % sign, etc.

5.16
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If you wish the number field data to be reformatted, check the Format as decimal number
button, and options regarding the number of decimal places, the use of commas in entries
with thousands, and notations governing currency and percentage will be available.

Formatting Date Fields

Dates in date fields and some calculation fields can be displayed and printed in a variety ways.
Dates can be formatted with the month spelled out or as a number, with a numerical date
separated by slashes (/) etc.

Formatting Time Fields

Times in time fields and some calculation fields can be displayed and printed in a variety ways.
Times can be formatted as hours, minutes and seconds, hours and minutes, separated with
different characters eg. :, as a 24 hour clock etc.
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Formatting Picture Fields

Pictures in Picture fields can be displayed and printed in a variety ways. Pictures can be
formatted as reduced in size to fit a frame, aligned centrally, etc.

Pictures in the layout are surrounded by a rectangle known as a frame. Choose how you wish
the picture to be formatted within the frame by making your choice from the pop-up menu
alongside picture to fit frame.

A box is provided to allow you to ensure that the proportions of the picture are maintained.
Vertical and horizontal alignment of the picture can be set by using the Alignment pop-up
menus.

Note: Not all picture formats can be displayed by the database.

Changing the Tab Order

By default, pressing the Tab (       ) key when entering data moves the insertion point to the
next field to the right or if there are no fields to the right the insertion point moves down to
the next field. You may wish to change the tab order so as to make it more logical for the user
of your database. You may also wish to omit fields from the tab order, for example, fields into
which you rarely enter data.

To change this tab order choose the Layout
mode from the Select menu, and choose
the Tab Order command from the Arrange
menu. The tab order dialog box will be
presented and numbered arrows are
displayed pointing to each field of the layout.

To edit the existing tab order click on the
numbered arrows and type the new position
of the fields in the tab order. The tab order
of the other fields will be re-ordered
automatically.

To create a new tab order click on the
Create new tab order button. This will
cause all the tab arrows to be shown blank.

5.17
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To specify a revised tab order, click on the arrows in the sequence you prefer, and a number
will be displayed inside each arrow to show you the revised tab order.

If you wish to leave fields out of the tab order either delete the number from the tab arrow
or if creating a new tab order, leave the tab arrow blank.

When you have completed editing the tab order click on the OK button.

If you have left any fields out of the tab order a dialog box will be displayed. Click on Omit
to keep the fields out of the tab order. Click on Add to attach the fields you left blank to the
end of the tab order.

Including Summaries in Your Database

You can use a summary to compute a value based on a selection of records. So, for example,
if our auto showroom owner wishes her database to calculate a total profit for auto sales,
she would use a summary to do this.

Summaries can be defined as part of a layout, appearing and being printed for example, at
the bottom of a layout. Alternatively, they can be defined as a separate layout displaying
summary information about the records in the main layout. See Section 5.19 to find out more
about using more than one layout.

Note: Summaries are a complex aspect of FileMaker Pro. Only the creation of Grand
Summaries are described in this guide. For more about Summaries see the Claris
FileMaker Pro User’s Guide.

There are two main types of summary:

Leading grand summary: Displays summary information before all records. Only one leading
grand summary per layout is permitted.

Trailing grand summary: Displays summary information after all records. Only one trailing
grand summary per layout is permitted. This is the most commonly used type of summary.

The type of summary must first be defined,
followed by the summary fields.

• Choose the Layout mode from the Select
menu.

• Drag the Part tool from the Status Area
to the position on the layout where you
wish the summary to be.

The Part definition dialog box is displayed.

• If the Part is dragged to precede the body
part a Leading Grand Summary can be
chosen, if otherwise a Trailing Grand
Summary can be chosen. Click on the
OK button.

• The name of the part type is listed on the
left of the layout. Parts are separated with
horizontal dotted lines.

5.18
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• Next, the summary fields can be defined. Choose the Define fields command from the
Select menu.

• In the dialog box presented type an appropriate field name for the summary and click on
the Summary field type. The dialog box below is displayed.

• From the pop-up menu on the left of the dialog box choose the type of function you wish
to use in the summary field and from the pop-up menu on the right choose the field you
wish to summarise. The most commonly used functions are:

Total – to total the contents of a field for all records.

Average – to average the contents of a field for all records.

Count – to count the number of records which contain a value for the field.

• Position the fields in the summary as required.

Tip: Occasionally the horizontal part names get in the way of the fields in the layout
mode. It can help to position the part names vertically. To do this click on the         part
label button at the bottom of the window.

Using More Than One Layout

Usually a single layout for a database is sufficient. However, more than one layout can be
useful to display a different selection of fields or parts. Switching between layouts is simply
a matter of choosing a different layout from a menu.

To use the auto showroom example, the owner might wish to use one layout to display the
records of each auto, and a different layout to display summary information like the profit
from sales of a particular type of auto.

To create an additional layout, choose the
New Layout command from the Edit menu.
Choose one of the pre-defined layouts from
the dialog box displayed, name the layout
and click on OK. See Section 5.1 about pre-
defined fields. Arrange the fields on this
layout as normal. To switch between layouts
choose the layout from the layout pop-up
menu on the Status Area.

5.19
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BUTTONS

Data entry into the database is sometimes undertaken by somebody other than the designer
of the database, eg. the auto showroom owner will not always enter data. So to simplify the
data entry process for another person FileMaker Pro includes Buttons. Commands which
would generally be executed using FileMaker Pro's menus can be assigned to buttons so that
novices can easily execute the data entry required in the database.

To define a button to carry out a command:

• Choose the Layout mode from the Select menu.

• Select an object you wish to use as a button. This can be any graphic object or text, but
not a field.

• Choose the Define Button command from the Scripts menu. This will display the dialog
box below.

Choose the command which you wish the
button to carry out from the scrollable list.
Some of the commands have parameters
which must be specified in the bottom section
of dialog box. Once the button is defined
click on the OK button and return to Browse
mode. Clicking on the button you have
defined will carry out the command.

Tip: A selection of well drawn buttons is
available by copying and pasting from
the buttons file in the Templates folder
supplied with FileMaker Pro.

To use the auto showroom example again,
by defining a button to perform the New
Record/Request command, the button can
be clicked instead of using the menu
command. Likewise defining another button
to perform the Go to Layout command and
specifying the auto showroom summary
layout will enable the user to easily switch to
the sales summary.

To Delete a Button

• Choose the Layout mode from the Select menu.

• Select the button you wish to delete and press the Delete or Backspace (←) key on the
keyboard.

Note: Buttons can also be used to carry out more than one command. To do this you need
to understand how to use FileMaker Pro’s scripting facility. Consult the Claris FileMaker
Pro Users Guide for more information.

Buttons can be Cut, Copied and Pasted between Layouts and databases, though the
parameters attached to buttons may need to be redefined.

6.0
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APPENDIX A

Import/Export

Moving data to and from other applications is extremely useful since it allows you to exchange
databases with other database applications and mix FileMaker Pro’s database capabilities
with the specialist features of a graphics or wordprocessing application. It also avoids both
the labour of re-typing and the possibility of introducing errors.

Importing Data

To import data into FileMaker Pro it must first have been saved in a format that FileMaker Pro
can open.

There are eight of these formats known variously as Tab-Separated Text, Merge, Comma-
Separated Text (CSV), BASIC, SYLK, WKS, DIF, Edition file, FileMaker Pro version 1. In most
cases you will import data as Tab-Separated Text or CSV form unless you are importing a file
from another database application.

Either, Open the Database into which you wish to import the data,

Or, Create a new database ready to accept the imported data. Define the fields into
which you wish to import data. Ensuring that there are at least as many fields created
as are being imported.

• While in Browse mode, choose the Import/Export command from the Edit menu and
the Import Records command from the pop-up sub-menu. Find the file that you wish
to import using the dialog box presented.

Note: If the file cannot be seen in the list displayed it cannot be opened by FileMaker Pro.
Return to original file format and Save as in a format which FileMaker Pro can read.

Databases imported from FileMaker Pro 1 into FileMaker Pro 2 can no longer be opened in
FileMaker Pro 1.

• Once opened the dialog box opposite will
be displayed.

• The left of the dialog box displays a list of
the data for import; the right hand side
displays a list of field names that you must
match this data to. Click and drag the
field names on the right until they match
with the data on the left.

• Click on OK and the data will be imported.

Note: Repeating fields cannot be
imported into a single field.

Importing FileMaker Pro Files Cross-Platform.

FileMaker Pro for Macintosh will import FileMaker Pro for Windows files directly and vice
versa, with a few considerations.
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• When importing FileMaker Pro files from Mac to Windows, ensure that the database you
wish to transfer has a filename with no more than 8 characters and a .fm extension.

• Fonts may appear a little different.

• The positioning of objects may be a little different.

Importing Files From Other Applications

Most data saved in the above formats on Macintosh or IBM PC compatible can be imported
into FileMaker Pro.

• The data must be saved in a format that FileMaker Pro will open. This can be any one of
the formats specified in above.

• If files are to be exported cross-platform the disk format must be made compatible. This
can be done by using the Apple File Exchange program supplied with every Macintosh.

• Once the disk format is readable import the file into FileMaker Pro as outlined above.

Exporting Data

There are two ways of exporting data to another application from FileMaker Pro:

• By Copying and Pasting data

• By using saved data

Using Copy and Paste

This method will only work when exporting to computers of a similar type ie. Macintosh to
Macintosh or IBM PC to IBM PC.

Hold down the Option key (Shift ( ⇑) key with FileMaker Pro for Windows) while choosing
Copy from the Edit menu. Close FileMaker Pro. Open the application into which you wish
to export the data. Move the insertion point to where you wish the data to appear and choose
Paste from the Edit menu, if pasted to a wordprocessor the data will be pasted delimited
by tabs.

Using Saved Data

Open the database you wish to export. Choose the Import/Export command from the Edit
menu, and the Export Records command from the sub-menu. Type a file name for the
exported file, select a file type from the file type pop-up menu and click on New to export
the file.

• Most applications on the Macintosh and IBM PC compatible can open files created in one
of the file formats which FileMaker Pro exports.

• If files are to be exported cross-platform the disk format must be made compatible. This
can be done by using the Apple File Exchange program supplied with every Macintosh.

• Once the disk format is readable simply open the file from within the application.
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APPENDIX B

There are a great many calculation functions built in to FileMaker Pro. However, you will use
only a handful of these on a regular basis and so the most common functions are listed below
with a brief explanation and the arguments they require. For a complete list of functions refer
to the FileMaker Pro User Guide.

Functions shown throughout this guide are illustrated with semi-colon separators.

Calculation Functions

Abs(number) Returns the absolute (positive) value of a number.

Date(month,day;year) Returns the long date format from numerical date.

DateToText(date) Returns the text equivalent of a date.

Day(date) Returns a number between 1 and 31 which represents the day
of the date.

DayName(date) Returns text which represents the weekday of the date.

DayofYear(date) Returns a number which represents the no. of days since 1st
Jan.

Exact(original text;comparison text)

Case-sensitive comparison between two pieces of text. Returns
1 if identical 0 if different.

Hour(time) Returns the number of hours shown in a time value.

If(test,resultone,resulttwo) See Section 3.3.

Int(number) Returns the integer (whole number) of a number.

Left(text;number) Returns the text containing the specified number of characters
as counted from the left.

Length(text) Returns the number of characters in the text.

Lower(text) Converts text to upper case.

Middle(text,start,size) Returns the text containing the specified number of characters
(size) as counted from the specified start character.

Minute(time) Returns the number of minutes shown in a time value.

Mod(number,divisor) Returns the number remaining after the number is divided by
the divisor.

Month(date) Returns a number between 1 and 12 which represents the
month of the date.

MonthName(date) Returns the month of the date.

NumToText(number) Returns the text equivalent of the supplied number.
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Position(text,search text,start)

Scan of text for the presence of search text from the position
specified by start. Returns a number where the text begins.

Proper(text) Converts text to title case.

Replace(text,start,size,replacement text)

Replaces the text with the replacement text from the position
specified by start and until size.

Right(text,number) Returns the text containing the specified number of characters
as counted from the Right.

Round(number,precision) Rounds the number to the number of decimal places defined
by precision.

Seconds(time) Returns the number of seconds shown in a time value.

Sign(number) Returns -0 or 1 depending on the sign of the value.

Summary(summary field,break field)

Extracts the value of the summary field for the records sorted
by break field.

TextToDate(text) Returns the date equivalent of the text.

TextToNum(text) Returns the number equivalent of the text.

TextToTime(text) Returns the time equivalent of the text.

Time(hours;minutes;seconds)

Returns a time result from the supplied values.

TimeToText(text) Returns the text equivalent of the time.

Today Returns todays date

Trim(text) Returns the text stripped of all leading & trailing spaces.

Upper(text) Converts the text to upper case.

WeekofYear(date) Returns a number which represents the no. of weeks since 1st
Jan.

Year(date) Returns a number which represents the year of the date.


